Архив рубрики: ИТ технологии

Docker. Создание билда и способ его переноса в другой docker.

Даже базовая работа с docker приводит к разбору многих нюансов. По этому надо часть из них законспектировать. Узнать абсолютный путь: pwd Создание файла: touch Dockerfile Посмотреть какие тома присоединены к контейнеру: docker inspect %ID_контейнера% Создание билда под linux: docker build —platform linux/amd64 -t image-name ./ Сохранить image в файл, для дальнейшего его переноса в другой… Читать далее »

Docker. Лог контейнера занимает много места.

Во время работы контейнера генерируются логи, просмотреть их можно при помощи команды docker logs <имя контейнера>. Сам лог хранится в каталоге «/var/lib/docker/containers/<id контейнера>/<id контейнера>-json.log». Чем дольше живет контейнер и чем больше генерирует логов приложение в нем — тем больший объем занимает этот лог. Для предотвращения нехватки дискового пространства нужно сделать ротацию этого лога. В Docker… Читать далее »

Docker. Перенос образа на другой компьютер

Имеем docker контейнер который нужно перенести на другой хост. По сути наша задача сводится с переносу образа на новый хост и запуску контейнера из этого образа. Смотрим на контейнер Посмотреть какие тома присоединены к контейнеру можно в разделе «Mounts» в выводе команды: Сохранение образа. На первом месте куда сохранять, на втором что сохранять. Копируем тома(volumes).… Читать далее »

MS SQL Server 2019 настройка, установка для 1С платформ.

Минимальные настройки, которые нужны для работы с 1С предприятием. Начнем с того, что вы уже определились какую версию хотите установить. Так же ознакомились с минимальными требованиями, которые нужны для установки MS SQL Server2019. А если нет, то система вам подскажет. Ну или поиск вам в помощь. Если вы дошли до выбора компонентов, тогда достаточно выбрать… Читать далее »

Горячие клавиши или сочетания клавиш Midnight Commander

СтруктураПанели каталогов:Tab, Ctrl + i сменить текущую (активную) панельInsert, Ctrl + t отметить файл либо снять отметкуAlt + g Alt + r Alt + j подсветка верхнего, среднего или нижнего файла из числа отображаемых на панелиAlt + t переключить режим отображенияCtrl + \ показать «Справочник каталогов»+ выбрать (отметить) группу файлов по регулярному выражению\ снять отметку… Читать далее »

Подключиться к Ubuntu из Windows при помощи RDP

Есть различные способы, но мы будем использовать стандартный для Windows это RDP. RDP — это протокол удалённого управления, который разработала компания Microsoft. Он подходит для удалённой работы пользователя с компьютером или сервером (в том числе с виртуальным сервером), на котором установлен сервис терминальных подключений. С помощью этого встроенного в Windows инструмента можно удалённо подключиться к… Читать далее »

Описание получения клиентских лицензий сервером 1C

Решение, которое казалось бы наипростейшее, но и в этом вопросе, чтобы понять его нужно разобраться. Поиск решения, конкретно для каждого случая, мне напоминает больше квест. Всегда остаются подводные камни или пасхалки, даже если изучишь все вроде бы досканально.

Кратное описание команд CMD

Хоть вроде бы этот механизм устарел, но иногда приходится его использовать. Так устроена наша память, что все помнить невозможно, но можно по «хлебный крошкам» восстановить последовательности, тем самым вспомнив алгоритмы и их возможное использование https://profcad.ru/profblog/data-ext-tems/bat-fishki.html Ссылка на страницу с описанием

Total Commander: его параметры и команды

Является хорошим дополнением к существующим файловым менеджером. И на мой взгляд является самым универсальным инструментом. Больше всего он подойдет тем, кому важен не только интерфейс но и множество дополнительных функций, которые можно как автоматизировать, так и подстроить под себя. Ниже ссылка на таблицу параметров которые можно и нужно использовать подстраивая ТС. profcad.ru/profblog/TC/TC-command-parameters.html Ссылка на таблицу… Читать далее »

1C: Математические вычисления

Функция Корень(Основание,Степень) Если Степень = 1 Тогда Возврат(Основание); КонецЕсли; Факториал = 1; Степень_ = 1; Сум = 0; СтепеньЕ = 1/Степень*Лог(Основание); Для ии = 1 по 28 Цикл Факториал = Факториал * ии; Степень_ = Степень_ * СтепеньЕ; Сум = Сум + Степень_/Факториал КонецЦикла; Возврат(1+Сум); КонецФункции