Архив рубрики: 1C Программирование

1C: Математические вычисления

Функция Корень(Основание,Степень) Если Степень = 1 Тогда Возврат(Основание); КонецЕсли; Факториал = 1; Степень_ = 1; Сум = 0; СтепеньЕ = 1/Степень*Лог(Основание); Для ии = 1 по 28 Цикл Факториал = Факториал * ии; Степень_ = Степень_ * СтепеньЕ; Сум = Сум + Степень_/Факториал КонецЦикла; Возврат(1+Сум); КонецФункции

Регулярные выражения

Синтаксис регулярных выражений Спец символы:  «[ ] \ / ^ $ . | ? * + ( ) { }» Если эти символы нужно представить в качестве символов текста, их следует экранировать обратной косой чертой «\». Значения символов в регулярных выражениях: «^» — каретка, циркумфлекс или просто галочка. Начало строки; «$» — знак доллара. Конец… Читать далее »